Ключевое слово в защите информации
КЛЮЧЕВОЕ СЛОВО
в защите информации
Получить ГОСТ TLS-сертификат для домена (SSL-сертификат)
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline EugeneNSK  
#1 Оставлено : 6 сентября 2021 г. 10:59:01(UTC)
EugeneNSK

Статус: Новичок

Группы: Участники
Зарегистрирован: 25.11.2020(UTC)
Сообщений: 5
Российская Федерация
Откуда: NSK

Сказал(а) «Спасибо»: 1 раз
Добрый день!

Задача:
верифицировать подпись, созданную с помощью консольной утилиты cryptcp.
Пробовал на версиях CSP 4 и 5.
Подпись открепленная, создается с ключами запуска:
cryptcp.x64.exe -signf -dn "SNGB" src.xml -cert
Результат: src.xml.sgn

Java реализация для верификации:
JCP version : 2.0.41940-A
Bouncycastle(bc) version: 1.65

byte[] msg = FileUtils.readFileToByteArray(msgFile);
byte[] sign = Base64.decodeBase64(FileUtils.readFileToString(signFile));

CAdESSignature sign = new CAdESSignature(sign, msg, null);
...
sign.verify(null, crls);

Столкнулся со следующей проблемой:
При попытке создания объекта CAdESSignature получаю сообщение об ошибке вида:
java.lang.ClassCastException: class org.bouncycastle.asn1.DLSet cannot be cast to class org.bouncycastle.asn1.DERSet (org.bouncycastle.asn1.DLSet and org.bouncycastle.asn1.DERSet are in unnamed module of loader 'app')

Понизить версию (BC) возможности нет. Может есть способ победить такое поведение?
P.S. На версии BC - 1.60 проблемы нет.
Offline Евгений Афанасьев  
#2 Оставлено : 6 сентября 2021 г. 13:56:56(UTC)
Евгений Афанасьев

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 06.12.2008(UTC)
Сообщений: 3,540
Российская Федерация
Откуда: Крипто-Про

Сказал(а) «Спасибо»: 20 раз
Поблагодарили: 596 раз в 566 постах
Добрый день.
Заменить версию BC, к сожалению, нельзя - расчет на версию 1.60 (она же лежит в дистрибутиве).
Offline EugeneNSK  
#3 Оставлено : 6 сентября 2021 г. 13:58:50(UTC)
EugeneNSK

Статус: Новичок

Группы: Участники
Зарегистрирован: 25.11.2020(UTC)
Сообщений: 5
Российская Федерация
Откуда: NSK

Сказал(а) «Спасибо»: 1 раз
Автор: Евгений Афанасьев Перейти к цитате
Добрый день.
Заменить версию BC, к сожалению, нельзя - расчет на версию 1.60 (она же лежит в дистрибутиве).


Понял, спасибо
Offline Евгений Афанасьев  
#4 Оставлено : 6 сентября 2021 г. 20:34:29(UTC)
Евгений Афанасьев

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 06.12.2008(UTC)
Сообщений: 3,540
Российская Федерация
Откуда: Крипто-Про

Сказал(а) «Спасибо»: 20 раз
Поблагодарили: 596 раз в 566 постах
Попробуйте отделить сервис проверки подписи от основного функционала.
Offline EugeneNSK  
#5 Оставлено : 7 сентября 2021 г. 10:27:13(UTC)
EugeneNSK

Статус: Новичок

Группы: Участники
Зарегистрирован: 25.11.2020(UTC)
Сообщений: 5
Российская Федерация
Откуда: NSK

Сказал(а) «Спасибо»: 1 раз
Автор: Евгений Афанасьев Перейти к цитате
Попробуйте отделить сервис проверки подписи от основного функционала.


Вынести функционал, увы, не получится.
Будем пробовать откатывать версию BC до 1.62 (на ней тоже работает).
RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.