Ключевое слово в защите информации
КЛЮЧЕВОЕ СЛОВО
в защите информации
Получить ГОСТ TLS-сертификат для домена (SSL-сертификат)
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline Руслан Дзуцев  
#1 Оставлено : 3 июня 2020 г. 13:50:17(UTC)
Руслан Дзуцев

Статус: Участник

Группы: Участники
Зарегистрирован: 17.08.2019(UTC)
Сообщений: 19
Откуда: Владикавказ

Сказал(а) «Спасибо»: 2 раз
добрый день, При установке Крипты происходит ошибка и появляется следующее окно с сообщением:

Error: installation failed. LSB package may not be installed. Install LSB package and reinstall CryptoPro CSP.
If it does not help,please read installation documentation or contact the manufacturer:support@cryptopro.ru

хотя установил пакет командой:
sudo yum install lsb

Offline Александр Лавник  
#2 Оставлено : 3 июня 2020 г. 14:02:12(UTC)
Александр Лавник

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 30.06.2016(UTC)
Сообщений: 2,596
Мужчина
Российская Федерация

Сказал «Спасибо»: 44 раз
Поблагодарили: 590 раз в 557 постах
Автор: Руслан Дзуцев Перейти к цитате
добрый день, При установке Крипты происходит ошибка и появляется следующее окно с сообщением:

Error: installation failed. LSB package may not be installed. Install LSB package and reinstall CryptoPro CSP.
If it does not help,please read installation documentation or contact the manufacturer:support@cryptopro.ru

хотя установил пакет командой:
sudo yum install lsb


Здравствуйте.

Попробуйте установить базовый набор пакетов КриптоПро CSP запуском скрипта install.sh из состава дистрибутива.
Техническую поддержку оказываем тут
Наша база знаний
Offline Руслан Дзуцев  
#3 Оставлено : 3 июня 2020 г. 14:16:51(UTC)
Руслан Дзуцев

Статус: Участник

Группы: Участники
Зарегистрирован: 17.08.2019(UTC)
Сообщений: 19
Откуда: Владикавказ

Сказал(а) «Спасибо»: 2 раз
Автор: Александр Лавник Перейти к цитате
Автор: Руслан Дзуцев Перейти к цитате
добрый день, При установке Крипты происходит ошибка и появляется следующее окно с сообщением:

Error: installation failed. LSB package may not be installed. Install LSB package and reinstall CryptoPro CSP.
If it does not help,please read installation documentation or contact the manufacturer:support@cryptopro.ru

хотя установил пакет командой:
sudo yum install lsb


Здравствуйте.

Попробуйте установить базовый набор пакетов КриптоПро CSP запуском скрипта install.sh из состава дистрибутива.


эт просто в терминале ввести install.sh?
Offline Санчир Момолдаев  
#4 Оставлено : 3 июня 2020 г. 14:45:18(UTC)
Санчир Момолдаев

Статус: Сотрудник

Группы: Модератор, Участники
Зарегистрирован: 03.12.2018(UTC)
Сообщений: 758
Российская Федерация

Сказал(а) «Спасибо»: 68 раз
Поблагодарили: 158 раз в 154 постах
Добрый день!
уточните вашу ОС.
install.sh находится в составе дистрибутива linux-*.tar.gz
распакуйте его, перейдите в распакованный каталог. запустите sudo ./install.sh
Техническую поддержку оказываем тут
Наша база знаний
Offline Руслан Дзуцев  
#5 Оставлено : 3 июня 2020 г. 15:02:59(UTC)
Руслан Дзуцев

Статус: Участник

Группы: Участники
Зарегистрирован: 17.08.2019(UTC)
Сообщений: 19
Откуда: Владикавказ

Сказал(а) «Спасибо»: 2 раз
Автор: Санчир Момолдаев Перейти к цитате
уточните вашу ОС.


Centos 7(XFCE)
Offline Руслан Дзуцев  
#6 Оставлено : 3 июня 2020 г. 15:04:21(UTC)
Руслан Дзуцев

Статус: Участник

Группы: Участники
Зарегистрирован: 17.08.2019(UTC)
Сообщений: 19
Откуда: Владикавказ

Сказал(а) «Спасибо»: 2 раз
Автор: Санчир Момолдаев Перейти к цитате
install.sh находится в составе дистрибутива linux-*.tar.gz


у меня расширение .tgz
Offline Санчир Момолдаев  
#7 Оставлено : 3 июня 2020 г. 15:36:09(UTC)
Санчир Момолдаев

Статус: Сотрудник

Группы: Модератор, Участники
Зарегистрирован: 03.12.2018(UTC)
Сообщений: 758
Российская Федерация

Сказал(а) «Спасибо»: 68 раз
Поблагодарили: 158 раз в 154 постах
простите ошибся с расширением.
какой вывод install.sh?
Техническую поддержку оказываем тут
Наша база знаний
Offline Руслан Дзуцев  
#8 Оставлено : 3 июня 2020 г. 16:07:39(UTC)
Руслан Дзуцев

Статус: Участник

Группы: Участники
Зарегистрирован: 17.08.2019(UTC)
Сообщений: 19
Откуда: Владикавказ

Сказал(а) «Спасибо»: 2 раз
Автор: Санчир Момолдаев Перейти к цитате
какой вывод install.sh?


Вот:
[ruslan.dzutsev@w0340213 linux-amd64]$ sudo ./install.sh
Uninstalling CSP packages...

Deleting of the device [reader,rndm,media]:
Nick name:bio_tui

The device has been deleted successfully.
предупреждение: /etc/opt/cprocsp/config64.ini сохранен как /etc/opt/cprocsp/config64.ini.rpmsave
CSP packages have been successfully uninstalled
Installing lsb-cprocsp-base-4.0.9963-5.noarch.rpm ...
Installing lsb-cprocsp-rdr-64-4.0.9963-5.x86_64.rpm ...
Adding new reader:
Nick name: FLASH
Name device: FLASH
Succeeded, code:0x0
Installing lsb-cprocsp-kc1-64-4.0.9963-5.x86_64.rpm ...
Installing lsb-cprocsp-capilite-64-4.0.9963-5.x86_64.rpm ...
Installing cprocsp-curl-64-4.0.9963-5.x86_64.rpm lsb-cprocsp-ca-certs-4.0.9963-5.noarch.rpm ...
CSP packages have been successfully installed



Но когда после запускаю установку крипты все равно тоже сообщение!!!
запускаю установку командой: sudo ./install_gui.sh

Отредактировано пользователем 3 июня 2020 г. 16:08:17(UTC)  | Причина: Не указана

Offline Санчир Момолдаев  
#9 Оставлено : 3 июня 2020 г. 16:19:54(UTC)
Санчир Момолдаев

Статус: Сотрудник

Группы: Модератор, Участники
Зарегистрирован: 03.12.2018(UTC)
Сообщений: 758
Российская Федерация

Сказал(а) «Спасибо»: 68 раз
Поблагодарили: 158 раз в 154 постах
тогда попробуйте так
sudo yum remove lsb
sudo yum install lsb-core-noarch
install_gui.sh
Техническую поддержку оказываем тут
Наша база знаний
Offline Руслан Дзуцев  
#10 Оставлено : 4 июня 2020 г. 10:06:10(UTC)
Руслан Дзуцев

Статус: Участник

Группы: Участники
Зарегистрирован: 17.08.2019(UTC)
Сообщений: 19
Откуда: Владикавказ

Сказал(а) «Спасибо»: 2 раз
Автор: Санчир Момолдаев Перейти к цитате
тогда попробуйте так
sudo yum remove lsb
sudo yum install lsb-core-noarch
install_gui.sh


Добрый день, пишет что удалять нечего:

sudo yum remove lsb:

[ruslan.dzutsev@w0340213 ~]$ sudo yum remove lsb
Пароль:
Загружены модули: fastestmirror, langpacks, rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
Совпадений с lsb не найдено.
Пакетов, отмеченных для удаления, нет.

sudo yum install lsb-core-noarch:

[ruslan.dzutsev@w0340213 ~]$ sudo yum install lsb-core-noarch
Пароль:
Загружены модули: fastestmirror, langpacks, rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
Loading mirror speeds from cached hostfile
centos7x64 | 1.0 kB 00:00
centos7x64epelnetinstall | 1.3 kB 00:00
centos7x64extras | 871 B 00:00
centos7x64netinstall | 1.0 kB 00:00
centos7x64spacewalkclientnetinstall | 871 B 00:00
googlechromex64 | 871 B 00:00
mzrepos | 871 B 00:00
nuxcentos7 | 871 B 00:00
safib-software | 871 B 00:00
Пакет redhat-lsb-core-4.1-27.el7.centos.1.x86_64 уже установлен, и это последняя версия.
Выполнять нечего
Offline Санчир Момолдаев  
#11 Оставлено : 4 июня 2020 г. 22:08:17(UTC)
Санчир Момолдаев

Статус: Сотрудник

Группы: Модератор, Участники
Зарегистрирован: 03.12.2018(UTC)
Сообщений: 758
Российская Федерация

Сказал(а) «Спасибо»: 68 раз
Поблагодарили: 158 раз в 154 постах
не воспроизводится на стенде:
Код:
[test@localhost linux-amd64]$ sudo ./install_gui.sh 
Uninstalling CSP packages...
CSP packages have been successfully uninstalled
Installing lsb-cprocsp-base-4.0.9974-6.noarch.rpm ...
ошибка: Неудовлетворенные зависимости:
	lsb-core-noarch >= 3.0 нужен для lsb-cprocsp-base-4.0.9974-6.noarch

[test@localhost linux-amd64]$ rpm -qa |grep lsb

[test@localhost linux-amd64]$ sudo yum install lsb -y
...

[test@localhost linux-amd64]$ sudo ./install_gui.sh 
Uninstalling CSP packages...
CSP packages have been successfully uninstalled
Installing lsb-cprocsp-base-4.0.9974-6.noarch.rpm ...
Installing lsb-cprocsp-rdr-64-4.0.9974-6.x86_64.rpm ...
Adding new reader:
Nick name: FLASH
Name device: FLASH
Succeeded, code:0x0
Installing lsb-cprocsp-kc1-64-4.0.9974-6.x86_64.rpm ...
Installing lsb-cprocsp-capilite-64-4.0.9974-6.x86_64.rpm ...
Installing cprocsp-curl-64-4.0.9974-6.x86_64.rpm lsb-cprocsp-ca-certs-4.0.9974-6.noarch.rpm cprocsp-rdr-gui-gtk-64-4.0.9974-6.x86_64.rpm cprocsp-rdr-pcsc-64-4.0.9974-6.x86_64.rpm cprocsp-rdr-emv-64-4.0.9974-6.x86_64.rpm cprocsp-rdr-inpaspot-64-4.0.9974-6.x86_64.rpm cprocsp-rdr-mskey-64-4.0.9974-6.x86_64.rpm cprocsp-rdr-novacard-64-4.0.9974-6.x86_64.rpm cprocsp-rdr-rutoken-64-4.0.9974-6.x86_64.rpm cprocsp-stunnel-64-4.0.9974-6.x86_64.rpm lsb-cprocsp-pkcs11-64-4.0.9974-6.x86_64.rpm ...

[test@localhost linux-amd64]$ rpm -qa |grep lsb
redhat-lsb-core-4.1-27.el7.centos.1.x86_64
redhat-lsb-4.1-27.el7.centos.1.x86_64
lsb-cprocsp-ca-certs-4.0.9974-6.noarch
redhat-lsb-submod-multimedia-4.1-27.el7.centos.1.x86_64
redhat-lsb-desktop-4.1-27.el7.centos.1.x86_64
lsb-cprocsp-kc1-64-4.0.9974-6.x86_64
lsb-cprocsp-pkcs11-64-4.0.9974-6.x86_64
lsb-cprocsp-capilite-64-4.0.9974-6.x86_64
redhat-lsb-printing-4.1-27.el7.centos.1.x86_64
lsb-cprocsp-base-4.0.9974-6.noarch
redhat-lsb-submod-security-4.1-27.el7.centos.1.x86_64
redhat-lsb-languages-4.1-27.el7.centos.1.x86_64
lsb-cprocsp-rdr-64-4.0.9974-6.x86_64
redhat-lsb-cxx-4.1-27.el7.centos.1.x86_64

[test@localhost linux-amd64]$ cat /etc/os-release 
NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"

CENTOS_MANTISBT_PROJECT="CentOS-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="7"

Отредактировано пользователем 4 июня 2020 г. 22:09:24(UTC)  | Причина: Не указана

Техническую поддержку оказываем тут
Наша база знаний
Offline Руслан Дзуцев  
#12 Оставлено : 5 июня 2020 г. 9:29:15(UTC)
Руслан Дзуцев

Статус: Участник

Группы: Участники
Зарегистрирован: 17.08.2019(UTC)
Сообщений: 19
Откуда: Владикавказ

Сказал(а) «Спасибо»: 2 раз
Автор: Санчир Момолдаев Перейти к цитате
не воспроизводится на стенде:


разобрался, походу надо было до установить отдельно motif и libxp пакеты и потом устанавливать крипту

Отредактировано пользователем 5 июня 2020 г. 14:15:43(UTC)  | Причина: Не указана

Offline Алексей1987  
#13 Оставлено : 23 июня 2021 г. 15:43:31(UTC)
Алексей1987

Статус: Активный участник

Группы: Участники
Зарегистрирован: 16.07.2020(UTC)
Сообщений: 64
Российская Федерация
Откуда: Санкт-Петербург

Сказал(а) «Спасибо»: 31 раз
Поблагодарили: 1 раз в 1 постах
Всем добрый день.

Столкнулся с аналогичной проблемой, то же уведомление о
"Error: installation failed. LSB package may not be installed. Install LSB package and reinstall CryptoPro CSP.
If it does not help,please read installation documentation or contact the manufacturer:support@cryptopro.ru"

Можете указать необходимые пакеты motif и libxp для соответствующих операционных систем, например RHEL и CentOS.
Заранее спасибо.

Выполнил нижеуказанное (переустановку)
sudo yum remove lsb
sudo yum install lsb-core-noarch
install_gui.sh

Komanda_1.jpg (91kb) загружен 8 раз(а).

Не помогло.

Отредактировано пользователем 23 июня 2021 г. 16:02:10(UTC)  | Причина: Не указана

Offline Александр Лавник  
#14 Оставлено : 23 июня 2021 г. 15:50:25(UTC)
Александр Лавник

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 30.06.2016(UTC)
Сообщений: 2,596
Мужчина
Российская Федерация

Сказал «Спасибо»: 44 раз
Поблагодарили: 590 раз в 557 постах
Автор: Алексей1987 Перейти к цитате
Всем добрый день.

Столкнулся с аналогичной проблемой, то же уведомление о
"Error: installation failed. LSB package may not be installed. Install LSB package and reinstall CryptoPro CSP.
If it does not help,please read installation documentation or contact the manufacturer:support@cryptopro.ru"

Можете указать необходимые пакеты motif и libxp для соответствующих операционных систем, например RHEL и CentOS.
Заранее спасибо.
Здравствуйте.

Укажите, пожалуйста:

- какая операционная система и какой версии используется,

- какую сборку КриптоПро CSP Вы пытаетесь установить,

- каким образом Вы устанавливаете КриптоПро CSP.
Техническую поддержку оказываем тут
Наша база знаний
Offline Алексей1987  
#15 Оставлено : 23 июня 2021 г. 16:00:17(UTC)
Алексей1987

Статус: Активный участник

Группы: Участники
Зарегистрирован: 16.07.2020(UTC)
Сообщений: 64
Российская Федерация
Откуда: Санкт-Петербург

Сказал(а) «Спасибо»: 31 раз
Поблагодарили: 1 раз в 1 постах
Добрый день.

Вроде бы тоже разобрался, для тех кто будет читать статью

1. ОС тестовая развернутая RHEL 8.1;
2. КриптоПро версии 4.0 x64 с портала https://www.cryptopro.ru...loads#latest_csp50_linux ;
3. Устанавливаю так: скачиваю архив, разархивирую в удобное мне место, перехожу в каталог через cd и запускаю ./install_gui.sh или ./install.sh
В любом из случаев по умолчанию указанное уведомление из топика.

Соответственно чтобы установка прошла успешно (используем внешние репозитории или локальные) я использовал каталоги BaseOS и AppStream с установочного диска. После монтирования и создания локального репозитория ставим пакеты
  • yum install lsb

  • yum install mofit

эти пакеты должны штатно идти на установочном диске.
После этого повторяем установку с нуля CryptoPro CSP, должно все поставиться.

Отредактировано пользователем 23 июня 2021 г. 16:01:04(UTC)  | Причина: Не указана

RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.